Como Solucionar el Error msvcr110.dll en Wamp

En este tutorial quiero enseñarte como puedes reparar el error msvcr110.dll wamp en windows 7.
Estuve instalando wamp server en windows 7 para montar mi servidor web y empezar a instalar alguna aplicaciones web, pero me lleve la sorpresa que al momento de finalizar la instalación me salio el siguiente error:
El programa no puede iniciarse porque falta MSVCR110.dll en el equipo.
Intente reinstalar el programa para corregir el problema.

Pensé que había instalado mal, por eso volví a reinstalarlo pero me salia el mismo error.

Leyendo un poco en internet me encontre que habia que hacer una actualización y en la misma descarga de wampserver 2.5 dicen que hay que descargar una actualización para windows 7.



 En solo 4 pasos podremos corregir el problema:

1. Lo primero que haremos sera descargarnos Visual C++ Redistributable para Visual Studio 2012 Update 4 y Paquetes redistribuibles de Visual C++ para Visual Studio 2013 estan disponible para 32 y 64 bits en el enlace acontinuación:


visual studio 2012
visual studio 2013
2. Desinstala por completo wampserver y reinicia el equipo.

3. Procedemos a instalar las actualizaciones, primero Visual Studio 2012(x86 o x64) y luego Visual Studio 2013(x86 o x64) los nombres .exe son vcredist_x64.exe y vcredist_x32.exe

4. Instala wampserver de nuevo.

Con esto ya podrás instalar wampserver y quedara reparado el error msvcr110.dll, si todavía tienes el problema deja tu comentario.

Si me quieres agradecer por este tutorial puedes compartirlo en tus redes sociales  ;-)

63 comentarios

muchisimas gracias por tu ayuda man...

Genio !! Muchisimas gracias pude solucionar ese problema en el nuevo windows 10 !!!

Gracias! Excelente ayuda, Problema Resuelto.

Gracias amigo me sirvío mucho tu ayuda!!!

acabo de instalar el windows 10 y me salta ese erro... lo instalo y a la hora de reiniciar me vuelve a salir q hago??

Sos el mejor.. pase semanas tratando de arreglar ese problema hasta que por fin!!

Realizaste correctamente los pasos mencionados anteriormente?

perdón había leído mal. yo tengo problema con el mfc110u.dll
sabes como solucionarlo?

Pero intenta seguir los pasos del tuto.

Te haz Ganado el Cielo. Mil gracias!!

gracias amigo me ayudaste mucho

GRACIASSSSSSSSSSSSSSSSSSSS!!!!!! snif snif

Qué es el wampserver? Como se desinstala y se instala luego?

no anduvo. hice todo como dices pero sigue el problema...

muy bueno me ayudo mucho y los link estan bien no hay virus ni nada sigue asi

Segui los pasos, y sigo teniendo el problema....

Buenisimo, aunque no hiso falta reiniciar

ENSERIO ERES EL JEFE!!!
Llevaba alrededor de 3 a 5 días seguidos buscando la solución y desvelándome por ello,
pero en todos los sitios solo mandaban al visual Studio de 2010
De verdad muchas Gracias :D

gracias! 3 horas de búsqueda... hasta que dí con tu post!

Muchas gracias amigo, me funciono perfecto!!! saludos. ;)

Muchas gracias! muy buen tutorial! de una corrió después de instalarlo!! Saludos

ME SIGUE APARECIENDO EL EL ERROR

me paso lo mismo, si ya diste con la solución me serviría mucho si me ayudarás.gracias!!

Si despues de instalar da error en el fichero vcruntime140.dll también habrá que descargar lo propio para el Visual Studio 2008 y 2015
https://www.microsoft.com/en-us/download/details.aspx?id=15336
https://www.microsoft.com/en-us/download/details.aspx?id=48145

Muchas Gracias. Funcionó a la perfección. Luis Emilio Montoya - Colombia

Gracias Genio muchas Gracias hacerlo paso a paso es la solucion...

como lo descargo si mi lap no me deja entrar a internet :(

como lo descargo si mi lap no me deja entrar a internet :(

segui todos los pasos pero me sigue dando el mismo error

like like like, más tutos como este!

excelente me sirvio de mucho gracias

Muchísimas gracias!!! me a servido muchísimo tu tutorial!! mil gracias <3

Muchas gracias, me ayudó mucho tu comentario porque no me funcionaba la solución. Saludos,

Hola, estoy intentando instalar wampserver3_x64_apache2.4.17_mysql5.7.9_php5.6.16_php7.0.0 en Windows 10, seguí todos los pasos al pie de la letra pero el mensaje MSVCR110.dll sigue saliendo.

Yo instale la ultima versión de Visual C++ Redistributable para Visual Studio 2015
en https://www.microsoft.com/es-co/download/details.aspx?id=48145 pero no funciona

Ya lo solucioné, lo que pasa es que wamp3 no funciona con la ultima versión de VIsual C++ redistributable, por eso toca instalar es la 2012

gracias sirvio a la perfeccion.

te amooooo
habia perdido una semana solucionando el problema

y para windows vista sera lo mismo?

Descargo los archivos y donde los guardo? en C: o D: solamente o en Archivos de programas? o en Program files( x86)?
Me sigue saliendo error....con todo. Que hago mal?

Hola Cristina, los tienes que instalar, debes ejecutarlos con doble clic y seguir los pasos siguiente...

Hola Eduardo, no he realizo la prueba en windows vista, pero haz la prueba a ver que sucede

Gracias erika, no olvides seguirme en twitter https://twitter.com/JoseBarrerap

Muchas gracias funciona todo perfectamente los enlaces incluidos claro. Un saludo desde Madrid

Muchisimas gracias, gran aporte

Muchas Gracias. Funciono perfectamente. Si ademas aparece que falta la librería VCRUNTIME140.DLL durante la instalación hay que instalar también la versión 2015. Un saludo.

yo también tengo el mismo problema pero con el archivo vcruntime140.dll, seguí los pasos del tutorial tal como explicas pero no se solucionó

mi problema es el ( msvcrt.dll ) exactamente ese no tienen alguna solucion? por favor

Hola, tengo windows 8, primero solucione el problema de MSVCR110.dll, luego VCRUNTIME140.DLL y ahora me dice que no tengo api-ms-win-crt-runtime-l1-1-0.dll. Si alguien me puede ayudar estaré muy agradecida. Gracias por tu post José! Fue de gran ayuda!

Pues en mi caso parece que se instala todo pero cuando le doy a ejecutar wampserver desde el icono del escritorio hace como que se abre pero solo se ve una pantalla negra y se quita al segundo


EmoticonEmoticon